clearFusionCMS Community
Installation problems - Printable Version

+- clearFusionCMS Community (http://community.clearfusioncms.com)
+-- Forum: clearFusionCMS Community Support (/forum-4.html)
+--- Forum: clearFusionCMS Support (/forum-7.html)
+--- Thread: Installation problems (/thread-137.html)

Pages: 1 2 3


Installation problems - John - 06-17-2013 05:15 PM

I installed the free version and followed all the steps at
http://docs.clearfusioncms.com/user-guide/installation/installing-clearfusioncms/
after I checked whether my host meets the requirements:
http://2cvqld.com/checkserver/
I also checked whether I have Ioncube installed:
http://2cvqld.com/phptest.php
But I get a 500 error at
http://2cvqld.com/
Any ideas?


RE: Installation problems - paul - 06-17-2013 05:27 PM

Hi John,

Did you rename htaccess.dist to .htaccess?
If so can you try renaming it out of the way as that error looks to be from Apache so I suspect it's something in the .htaccess file that's causing the issue.

If you didn't use htaccess.dist what is the contents of your .htaccess file

Paul


RE: Installation problems - John - 06-17-2013 05:38 PM

Same problem when I renamed .htaccess to htaccess.txt.
I restored .htaccess and this is the content:

# Rewrite to search engine friendly URLs
RewriteEngine on
# RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^.*$ index.php

# Disable directory indexes
Options -Indexes


RE: Installation problems - paul - 06-17-2013 05:43 PM

Do you have an error_log with anything in it?

Is the index.php file writable by everyone or by group?
On some servers they don't allow PHP files to be world or group writable.

If not can you drop me your FTP details so that I can have a look at it.


RE: Installation problems - John - 06-17-2013 05:51 PM

There are heaps of lines like this in the error log:

[Mon Jun 17 19:49:58 2013] [error] [client 144.137.143.227] SoftException in Application.cpp:256: File "/home/twocvqld/public_html/index.php" is writeable by group

I tried a few different combinations as permissions but that does not make a difference.

Seems to have fixed it: used 644 as permissions


RE: Installation problems - paul - 06-17-2013 06:10 PM

Hi John,

It was the configuration of the server not liking PHP to be too writable, should work now, if not let me know.

Paul


RE: Installation problems - John - 06-17-2013 06:36 PM

Now it stops at step 2 of the installation, because "MySQLi available"


RE: Installation problems - paul - 06-17-2013 06:57 PM

Hi John,

If you can PM me your database info, username + pwd + database name, I'll go through the install to make sure there's nothing else that's going to trip it up.

This is the first server I've had issues with, I'm a bit surprised it doesn't have mysqli enabled but the installer should have fallen back to mysql, I've fixed that now.

Paul


RE: Installation problems - paul - 06-17-2013 08:08 PM

It seems our ZIP file for clearFusionCMS Free was somehow corrupted, I went back to the released code uploaded it and it all just worked, somehow when we built the ZIP some of the files had their ends chopped off.

I'm just repacking the Free version to put backup on our site for download, but your install should be working fine now, I've PMed you the logins.

Any issues just let me know.


RE: Installation problems - John - 06-17-2013 09:26 PM

Thanks Paul, all working beautiful now.
Now I just need to feel my way around.

Thanks again